You must be logged in to post messages.
Please login or register

Crusader, Warchest, & Extreme: General Discussion & Help
Moderated by peter2008, Lord Michael I, Lord_of_Hell

Hop to:    
Welcome! You are not logged in. Please Login or Register.1 reply
Stronghold 2 » Forums » Crusader, Warchest, & Extreme: General Discussion & Help » GameRanger And Stronghold Crusader Versions
Bottom
Topic Subject:GameRanger And Stronghold Crusader Versions
bobthcat377
Archer
posted 05-13-17 22:17 EST (US)         
Hey this is probably a way too simple question I could look up but I love this community.

Does GameRanger work with all versions? For example - A steams SC HD and a disc SC HD?

Thanks Y'all...
AuthorReplies:
EaglePrince
Archer
posted 05-14-17 06:26 EST (US)     1 / 1       
Yes, it does work with all versions of Stronghold Crusader.

However, not all versions of Stronghold Crusader are compatible with each other. On one hand you have versions 1.0, 1.1, and 1.2 which work fine together, while the version 1.3 isn't compatible with those three. Or to put it differently: all non-HD are compatible with each other, while HD is compatible with none of them.

Steam version is 1.3, and of course, it is compatible with non-Steam 1.3 version.

Just to avoid the confusion for other readers, though you know it:
-HD version is 1.3.
-non HD versions are 1.0, 1.1, and 1.2.
-Steam version is HD.
-Not all HD versions are Steam versions. Anybody who has a retail copy of Stronghold Crusader can get install the HD patch.
You must be logged in to post messages.
Please login or register

Hop to:    

Stronghold 2 | HeavenGames