You must be logged in to post messages.
Please login or register

Technical Issues
Moderated by Lord_of_Hell

Hop to:    
Welcome! You are not logged in. Please Login or Register.25 replies, Sticky
Stronghold 2 » Forums » Technical Issues » "Can't authenticate the CD inside the time" or "a security module can not be activated"
Bottom
Topic Subject:"Can't authenticate the CD inside the time" or "a security module can not be activated"
Sir Archeron
Archer
posted 11-26-05 20:31 EST (US)         
Sorry, but this is in portuguese:

I'm using my original cd, not backup! HELP!

Por favor, me ajudem brasileiros! Estou usando disco original!


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 12-09-2005 @ 09:43 AM).]

AuthorReplies:
PCDania
Archer
(id: PCD)
posted 11-27-05 05:18 EST (US)     1 / 25       
If you have any of the following programs running in the background, you will have to either disabling them or uninstalling them because the new version of Securom doesn't like these programs and others like those:

Alcohol 120%
BlindWrite
Daemon Tools
Game-Jack
CloneCD
Game Jackal
Xoom Game Clone
CDSpace
Virtual CD
Fantom CD
Anti-Blaxx
GetRight
Virtual Drives
Speaking Clock
Nero ImageDrive (this one is a maybe)

You might also like to disable your antivirus software.

There's more help to be found in this thread:

Disc can't be authenticated? wtf!?


"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 04-04-2006 @ 11:11 AM).]

Sir Archeron
Archer
posted 11-27-05 09:27 EST (US)     2 / 25       
I've done everything i could, but now, it says "A security module cannot be activated...". WHY?

EDIT: Sorry, i did not know that Anti-Blaxx was running. But now, the same initial problem! "Disc cannot be identified inside the time limit" HELP!


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 11-27-2005 @ 09:39 AM).]

PCDania
Archer
(id: PCD)
posted 11-27-05 13:17 EST (US)     3 / 25       
You have tried those programs that slows your CD-drive? There are links in the thread I linked to (sounds a bit confusing, hope you get it).

Have you checked the CD for scratches and fingerprints?


"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Sir Archeron
Archer
posted 11-27-05 14:35 EST (US)     4 / 25       
Nero DriveSpeed: Nothing
Tweak-XP: Again nothing
Cleaning CD: What you want me say? Nothing...

The same problem after this all.


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

PCDania
Archer
(id: PCD)
posted 11-27-05 16:00 EST (US)     5 / 25       
Any chance of using another CD- or DVD-drive for playing? I'm afraid it starts looking like your DVD-drive doesn't like the SecuROM on the SH2 CD

You could try see if there's is a firmware update for your DVD-drive as that sometimes help. If there is a firmware update for your DVD-drive it's important to follow the instructions for installing it to the point.


"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 11-27-2005 @ 04:01 PM).]

Sir Archeron
Archer
posted 11-27-05 16:25 EST (US)     6 / 25       
I've tested on my 2 drives, one is DVD-ROM/CD-RW/CD-ROM, and the other is CD-RW/CD-ROM. DVD-Rom from 2004, and CD-RW from 2002. Nothing on the two...

If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 11-27-2005 @ 04:26 PM).]

PCDania
Archer
(id: PCD)
posted 11-27-05 18:13 EST (US)     7 / 25       
It's rare to see a computer with two optical drives where none of them will read the SecuROM on the CD.

Have you tried checking if there's a firmware update for any of your optical drives?

Honestly I don't think it has anything with spyware to do but you could try check your computer for spyware with a freshly updated antispyware program like Spybot Search&Destroy. It's freeware, just remember to update it before you run it. As I said I don't think it solves the problem but one never knows as strange things do happen with computers now and then.


"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Sir Archeron
Archer
posted 11-28-05 13:01 EST (US)     8 / 25       
I've checked it with Lavasoft Ad-Aware SE Personal newest version, Microsoft Anti-Spyware, Spybot-S&D and Avast! 4.3 Free. Nothing with those four, the Dvd-ROM drive is from LG (no updates for this), and the CD-RW too, but there's an update.

I'll try, if nothing, then i post here.

EDIT: Sorry, i was wrong, there's no Firmware update for none of these.


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 11-28-2005 @ 01:05 PM).]

PCDania
Archer
(id: PCD)
posted 11-28-05 13:24 EST (US)     9 / 25       
I'm afraid I've run out of ideas except getting a new drive

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Sir Archeron
Archer
posted 11-28-05 16:31 EST (US)     10 / 25       
I don't know WHY Firefly/2k Games had the IDEA of changing from SafeDisc to SecuROM! I think i'll need to buy a new copy of the game, first waiting up to more 5 months until it comes to Brazil. I've buyed this copy on USA, but now i'm living in Brazil. The DVD-ROM Drives are not cheap here! And also because whe need to pay in R$!

If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

Thorney
Archer
posted 11-28-05 20:50 EST (US)     11 / 25       
Should sticky this

Quoted from Darren:

It is possible to obtain a solution to this problem by contacting SecuROM. Open the folder, in which you installed Stronghold 2 and locate the "stronghold2.exe" file. Right click on the file, select "Launch Analysis", and follow the on-screen instructions. A file named "analysislog.sr0" ought to be available in your root directory (e.g. C:\analysislog.sr0). Send this file, as well as a "DirectX Diagnostic" report, to support@securom.com.

PCDania
Archer
(id: PCD)
posted 11-29-05 05:38 EST (US)     12 / 25       
Good idea Thorney and thanks for finding that quote from Darren.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 11-29-2005 @ 05:39 AM).]

Makkenhoff
Archer
posted 11-29-05 19:24 EST (US)     13 / 25       
Quoted from Darren:

It is possible to obtain a solution to this problem by contacting SecuROM. Open the folder, in which you installed Stronghold 2 and locate the "stronghold2.exe" file. Right click on the file, select "Launch Analysis", and follow the on-screen instructions. A file named "analysislog.sr0" ought to be available in your root directory (e.g. C:\analysislog.sr0). Send this file, as well as a "DirectX Diagnostic" report, to support@securom.com.

<------------>

I did that, after 2 emails, got a "working" reply (One that wasn't a form.) And, it didn't work. So on with round 3. I'll update my post when I have a working game again. Round 3 update: Got a new exe from them, didn't work. Round 4 got me a developer response, to which he instructed me to use a regular user account, as opposed to the administrator, to which I did.. and a new error, so back to square 1. For me, its a cd-rom driver issue.. or a securerom issue, whichever side you see it from. More updates to follow if they give another reply. If they don't... well, I'm not sure what my options are then. As of email #5, I have a working game, but only on my test account. admin is still broken. So I can play now at least.

[This message has been edited by Makkenhoff (edited 12-01-2005 @ 01:33 PM).]

Sir Archeron
Archer
posted 12-01-05 12:40 EST (US)     14 / 25       

Quoted from Thorney:

Should sticky this

Quoted from Darren:

It is possible to obtain a solution to this problem by contacting SecuROM. Open the folder, in which you installed Stronghold 2 and locate the "stronghold2.exe" file. Right click on the file, select "Launch Analysis", and follow the on-screen instructions. A file named "analysislog.sr0" ought to be available in your root directory (e.g. C:\analysislog.sr0). Send this file, as well as a "DirectX Diagnostic" report, to support@securom.com.

I've did that, but what they said helped nothing.


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 12-01-2005 @ 12:46 PM).]

teowit
Archer
posted 12-01-05 13:57 EST (US)     15 / 25       
Hi,

I tried to see if my problem was already solved but I can see there is alot of people with problems.
In my case I "sometimes" can get my game to start. I do this by taking out the disc, re-entering it, waiting for the message that autoplay doesn't work and then after 3.45720587 seconds I double click the "play stronghold 2" shortcut . If I don't take out the disc, it never works. If there is no disc at all the computer freezes.

Sometimes (not very often) this works and the game starts. Most of the time my computer freezes completely and I need to push the big button and pray my system will restart without problems. I have a HP Compaq NW8000. I see the same problems like the other persons that the timing in version 1.3.1 is very narrow. I can not return my disc to the shop because they'll think I had made a copy. I have waited more or less 1.5 years since I last bought a game! and I am really disatified. What is happening for solving this problem ? Please help me. I tried all you have told but only the above solution works very seldom.

Thorney
Archer
posted 12-01-05 14:35 EST (US)     16 / 25       

Quoted from Makkenhoff:

As of email #5, I have a working game, but only on my test account. admin is still broken. So I can play now at least.

Could you describe in detail what steps you took? Maybe it will help these guys

Sir Archeron
Archer
posted 12-01-05 17:56 EST (US)     17 / 25       

Quoted from Makkenhoff:

As of email #5, I have a working game, but only on my test account. admin is still broken. So I can play now at least.

I had it tried, but it takes up to 30 minutes, and have the same problem. I sent another email for support@securom.com , and let's see what they reply...

Quoted from Thorney:

Could you describe in detail what steps you took? Maybe it will help these guys

I've already seen this method, but don't worked for me. Ok, here it is:

"First, create a new Windows Account with any name you want. Set it type to Limited Account, and create a password for it. Right click at your Stronghold 2 Exe and choose Run As. Write in the Account name (I used Stronghold 2) and the Account password (I think you MUST create a password)."


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 12-01-2005 @ 06:03 PM).]

Lord_Bugman
Archer
posted 12-02-05 09:20 EST (US)     18 / 25       
It will be securom, not your drive which is at fault.

I had huge problems with other games (not stronghold 2) until I flashed my dvd drive with the latest bios which for some reason, benq have now made region 0. Lucky me!

You could also fiddle with telling your system that you only have a 1 speed cd-rom in the device manager.

Oh and try setting the .exe to windows 2000 compatability

Bugman

Thorney
Archer
posted 12-02-05 10:39 EST (US)     19 / 25       
If anyone having problems hasn't been here already, here is the support advice direct from SecuROM. All of the SH2 error messages associated with failing to launch the game are here:

SecuROM Messages Description

Basically boils down to "we think your disc is a copy" and "don't use other software we object to" If you have not tried the steps outlined, please do so. You must eliminate existing solutions before expecting to get further support. Use or continue using the support email and hopefully they will address outstanding problems in a more definitive way.

And again the error reporting instructions as described by Darren:

Please consult the following steps to generate this analysis file.

Makkenhoff
Archer
posted 12-03-05 14:36 EST (US)     20 / 25       
If you send them the required information, they will work with you. I was able to get mine working with their help, as I truely use the original cd. However.. if your not using the original cd, its possible they can detect that, as no one has taken the time to decode/decompile the report that the log generator gives. It is possible I sent them a lot more information than is obvious to me. But, I followed the instructions and it did work. Sorry to those who aren't having the same luck. All you CAN do is what they tell you to do. I'm more confident that Securerom will address future issues I may have with the products they support, and while it is annoying... if I want the game, I'll do what it takes, or not buy it at all.

It took me in total 10 emails between me and securerom (5 a piece) to get it working on my test account. A highly irritating thing to be sure. I think I'm going to be checking which copy protection the games I'm thinking about buying are using now.. as this whole thing just has been invasive, and a bother all together, I don't think its worth it to me.

Thought this might interest some of you.

Dear Customer,


We're sorry to say that you will not be able to play on your admin account in the foreseeable future.
Our developers are still trying to fix the issue and we hope that it will be solved in the next SecuROM version.

Thank you for your great cooperation and patience!

If you have any questions, please feel free to ask.

Best regards,

SecuROM Support Team
SecuROM on the web: http://www.securom.com
or via e-mail: support@securom.com

So, my only fix is to use my temp account.

[This message has been edited by Makkenhoff (edited 12-03-2005 @ 03:32 PM).]

Sir Archeron
Archer
posted 12-05-05 17:32 EST (US)     21 / 25       
I've reinstalled all the game, with the SecuROM Support guide, and worked.

Now is 12-07-2005 01:30 PM, and until 12-05-05 17:32 the game worked fine, but now it's saying "Original disc could not be found or authenticated."!!! And i've did not removed the CD, nothing different from 12-05-05 17:32, the same configs, i've didn't changed nothing in my computer after that date, but today isn't working!!! HELP AGAIN!


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 12-07-2005 @ 10:31 AM).]

Makkenhoff
Archer
posted 12-11-05 00:07 EST (US)     22 / 25       
If you updated it while playing (it didn't restart the client) the protection technology might not kick in until after you restart the client, if thats what you did then there isn't much you can do.
Sir Archeron
Archer
posted 12-12-05 11:20 EST (US)     23 / 25       
No, i've reinstalled the game that day, downloaded the patch and applied it outside the game, then it worked for about 3 days and then, in an unexpected way, it got this error again!

UPDATE: I've discovered that my CD-RW drive don't support SecuROM, and thats the problem.

UPDATE AGAIN ON NEXT DAY: I've tested now with the Combo Drive (DVD-ROM; CD-RW; CD-ROM) and worked!


If i'm posting something about bugs, lag or errors, this is my system:

Athlon XP (not Sempron) 2400+, Windows XP SP2, GeForce FX 5200 123MB Ram from Inno3D, 16x DVD-ROM, 52x CD-ROM (2), 512 MB RAM DDR,
DirectX 9.0c, Onboard Audio (Via), Soyo KT600 Dragon Plus (Via chipset).

[This message has been edited by Sir Archeron (edited 12-20-2005 @ 07:15 AM).]

PCDania
Archer
(id: PCD)
posted 04-12-06 09:50 EST (US)     24 / 25       
Changed the title of the thread so it's easier for people to find.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Mathew Steel
Archer
posted 07-20-10 06:05 EST (US)     25 / 25       
if it happens again make sure that there isnt any spyware on it for it can mess with the game
You must be logged in to post messages.
Please login or register

Hop to:    

Stronghold 2 | HeavenGames