You must be logged in to post messages.
Please login or register

Technical Issues
Moderated by Lord_of_Hell

Hop to:    
Welcome! You are not logged in. Please Login or Register.3 replies
Stronghold 2 » Forums » Technical Issues » install error - is_string_not_defined
Bottom
Topic Subject:install error - is_string_not_defined
kiralsuir
Archer
posted 09-03-06 09:30 EST (US)         
Hello. This is my first time posting in this forum so please forgive me if I posted in the wrong place.
I recently brought stronghold2 deluxe (the single dvd version) but every time I try to install it gets part way through then gives the following error:
Feature transfer error
Feature is: ***IS_STRING_NOT_DEFINED***
component: maps
File: c:\program files\firefly studios\stronghold 2\maps\foug?es.sc2
Error: The filename, directory name, or volume label syntax is incorrect.

I was wondering if anyone knew how to get around this error or if my dvd needs replacing?
Thanks in advance.

AuthorReplies:
PCDania
Archer
(id: PCD)
posted 09-03-06 11:53 EST (US)     1 / 3       
The filename your computer can't read is in the French language and I guess your computer is set up as default to use a non-european language.

Try go to International and Language settings in Control panel and on the Language pane set your computer to use English (you might have to add a language) and on the Advanced pane choose the same language as on the Language pane. You will need the installation CD for your operating system for making above changes.

After you have installed the game you can go back and change the settings back to what they were.

I guess Tarbo might have something to add to above so please add in as necessary Tarbo


"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Tarbo
Archer
posted 09-03-06 13:14 EST (US)     2 / 3       
Of course I have something to add. I always have something to add. (And when I don't, that rarely stops me, anyway.)

Strictly speaking, it should suffice to change the detection for non-Unicode programs. You can find this in the "Advanced" tab, under "Regional Settings", in the Control Panel. Try "French (France)". If that doesn't work, you can try nearby languages as Spanish or Italian.

Just to play safe, make sure codepage 28605 is ticked in the box below. That should enable ISO-8859-15 (Latin) encoding.

If none of those get the job done, you could try changing your OS base language like PCDania suggested.

We first encountered this issue (and its solution) some time ago: <http://stronghold.heavengames.com/cgi-bin/forum/display.cgi?action=st&fn=26&tn=2789&st=11#post12>.

The problem is that the Ť (e accent grave) isn't a US-ASCII character, and some character sets represent it differently. If these representations do not match on other systems, you get a different character (if it isn't recognized, mostly a question mark). Your OS tries to handle it with Unicode (hence the 'r' disappears as well) but doesn't find a valid symbol.


"She displayed amazing skill in squeezing epic mistakes in tiny opportunities."
"You haven't had enough coffee until you can sneeze with your eyes open."
"Education should be treated like an expensive watch: never struck out just to show you have one."
"Always be wary of any helpful item that weighs less than its operating manual."
kiralsuir
Archer
posted 09-03-06 13:34 EST (US)     3 / 3       
Thanks guys! The problem was the Unicode thing, for some reason even though I live in England and this is an English computer the Unicode was set to Korean. I just switched it back to English and its all working perfectly, it also fixed some other problems I have been having.

So I just installed the game and Iím going to go and give it a try. Thanks for all your help, I would have never thought to have checked the Unicode myself ^^;

You must be logged in to post messages.
Please login or register

Hop to:    

Stronghold 2 | HeavenGames